My New Find "Bally's Baby Pac-Man" UPDATED!!

Restoration/upgrades/fixes/fabrication of pins and vids
User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

Picked this up tonight for almost free.

I cleaned the hell out of it, as it has been in a barn for 6 years.
Mr cleaned and waxed the playfield.
Simple green on the cabinet and plastic pieces.
All the rubbers are dried up.
No playfield pieces are missing
Plastics aren't broken.
Art work is good to very good.
So Far I have noticed the battery may have leaked , I cut it off as per a members recommendation.
Missing one 15 amp fuse.
No wires look cut or modified
the coin mec is gone but the micro switches are still mounted and hooked up
Marquee light comes on
monitor comes on but is blank.
Green light flashes on the board on the top right. then goes out.
sound test button on the bottom board makes a test noise
video test button doesn't do anything
playfield isn't lit up at all. (15 amp fuse maybe)?

Any way I downloaded the manual and schematics. Ill start troubleshooting tomorrow with the hope that I can get lots of advice from you guys. I will listen and follow direction. So after I replace the missing fuse......MY MOST IMPORTANT QUESTION IS>>>>Where is the most logical place to start my journey.

Thanks so much guys I am really looking forward to starting a non working project and getting the reward in the end.
Attachments
DSC_0416.JPG
DSC_0415.JPG
DSC_0414.JPG
DSC_0413.JPG
DSC_0412.JPG
DSC_0411.JPG
DSC_0409.JPG
DSC_0408.JPG
DSC_0407.JPG
DSC_0406.JPG
Last edited by dannyc99 on Fri Jan 23, 2015 8:34 am, edited 3 times in total.

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man"

Post by dannyc99 »

Last pic with missing fuse
Attachments
DSC_0420.jpg

User avatar
HPR Pinball
MAACA OG
Posts: 7471
Joined: Thu Sep 16, 2010 4:53 pm
Location: St-Rose, Laval
Has liked: 1 time
Been liked: 14 times

Re: My New Find "Bally's Baby Pac-Man"

Post by HPR Pinball »

Nice find, i really want to buy one in the future !

What to check first is the power supply, the connectors, the boards pins solders.
The will fix 95% of the possible problems.
Inventory
Pins: http://www.pinballowners.com/hal-9ooo
Vids: http://www.arcade-museum.com/members/me ... _id=454505
Les arcades, j'suis tombé d'dans quand j'tait pti !! :-)

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man"

Post by dannyc99 »

Well its obvious the leaking battery has caused issues. When the machine turns on the led on the same board flashes green twice.

I have a monitor that powers up but no picture and the playfield does not light.

the bottom board in my picture has two test buttons one for sound and one for video. the sound test works the video does nothing.

I did replace all the fuses.

So main question first is ...If one board does not work would that make the entire system not function.?

User avatar
sylvain
MAACA Wacko
Posts: 3460
Joined: Thu Nov 19, 2009 7:39 am
Location: Ottawa, Ontario
Been liked: 1 time

Re: My New Find "Bally's Baby Pac-Man"

Post by sylvain »

The game MPU is not booting, probably due to corrosion at the bottom of the board
(two flashes indicate that the 5101 CMOS RAM at U8 has problems with its socket, board copper traces,
board via holes, or the 5101 chip itself.

Bally & Stern MPU LED flashes documentation is available here:
http://www.pinwiki.com/wiki/index.php?t ... h_Sequence

With the MPU not booting, the video picture probably will not work,
and certainly not the score displays nor the controlled lamps. Nor any solenoids.
But the General Illumination (always on) lamps should work, if the fuses for the GI are actually good
and nothing else opened. The Sound self-test would work if the sound board and speaker are good
(and the supply to it good).

This machine is not an easy one to repair for a newbie, due to the additional video components on it.
However there is a lot of Bally MPU pinball repair info on the web now, it should help...

- Sylvain.
Looking for Bally Star-Jet, Capersville or The Wiggler, Williams Magic City, Grand Lizard, Swords of Fury, 1986 Pinstar Gamatron, and a few others.
Collecting & repairing electro-mechanical and solid state pinball machines with quality and care for over 35 years.
Serious and fun hobby, powerful nostalgia !

User avatar
gorydeath
MAACA QuarterPounder
Posts: 258
Joined: Tue Oct 05, 2010 12:58 pm
Location: peterborough

Re: My New Find "Bally's Baby Pac-Man"

Post by gorydeath »

Own it three times and is still in my top ten of machines i love. Even had a joystick put on one of my pinmames so i could play it.
Good luck and enjoy
i live

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man"

Post by dannyc99 »

sylvain wrote:The game MPU is not booting, probably due to corrosion at the bottom of the board
(two flashes indicate that the 5101 CMOS RAM at U8 has problems with its socket, board copper traces,
board via holes, or the 5101 chip itself.

Bally & Stern MPU LED flashes documentation is available here:
http://www.pinwiki.com/wiki/index.php?t ... h_Sequence

With the MPU not booting, the video picture probably will not work,
and certainly not the score displays nor the controlled lamps. Nor any solenoids.
But the General Illumination (always on) lamps should work, if the fuses for the GI are actually good
and nothing else opened. The Sound self-test would work if the sound board and speaker are good
(and the supply to it good).

This machine is not an easy one to repair for a newbie, due to the additional video components on it.
However there is a lot of Bally MPU pinball repair info on the web now, it should help...

- Sylvain.
The sound test does work. I am going to take the mpu board to Dan (Ballyboy) and have it fixed.
The vidiot board flashes twice and the sound does work. All of the test points have proper voltages and the always on lights (I assume the marquee light) is on.

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

So we Bally Boy and I worked on the boards last night,(mostly dan) and here is what I get now....
The MPU Board flashes properly but the vidiot board flashes so fast I cant figure it out. The first video shows both boards flashing, first the mpu then the vidiot.

The second video is whats happening on boot up with the screen and playfield.

As per the instructions the vidiot board should flash with the first flash coming on one second after power on and flashes 2,3 one sec apart. flashes 4,5,6 are much faster and closer together and 7,8,9 are very fast and hard to count then a two second pause and a tenth flash.

Let me know what you think.

https://www.youtube.com/watch?v=ZxMaYRK7LoA (MPU and Vidiot)

https://www.youtube.com/watch?v=rjunejGYKd8 (Screen and playfield.)

User avatar
Sparky
MAACA OG
Posts: 23130
Joined: Tue May 21, 2013 5:33 pm
Location: Saint-Lazare, west of MTL
Been liked: 11 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Sparky »

I think your game is working! Your playfield lamps are flashing exactly like the attract mode, except you have a few dead bulbs. See this video as a comparison:



As for your monitor, I see it flash just liek when the image changes in attract mode. It just seems out of adjustment. The horizontal sync is out of whack.
Patron saint of lost pinball causes.

Stage 5B. All except for NIB crap.

viewtopic.php?f=3&t=4742&p=40349&hilit=stages#p40349

User avatar
Sparky
MAACA OG
Posts: 23130
Joined: Tue May 21, 2013 5:33 pm
Location: Saint-Lazare, west of MTL
Been liked: 11 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Sparky »

I think your game is working! Your playfield lamps are flashing exactly like the attract mode, except you have a few dead bulbs. See this video as a comparison:



As for your monitor, I see it flash just liek when the image changes in attract mode. It just seems out of adjustment. The horizontal sync is out of whack.
Patron saint of lost pinball causes.

Stage 5B. All except for NIB crap.

viewtopic.php?f=3&t=4742&p=40349&hilit=stages#p40349

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

I will try and play with that tonight here is what I am concerned about

NO OR BAD VIDEO:
assuming the 13" monitor is working the first thing to suspect is the TMS9928 chip at u16, as this 40 pin chip is very problematic. If this chip is having problems the video will be distorted or wont sync properly. but u will have some sort of video.

This was taken from my repair manual.

User avatar
Sparky
MAACA OG
Posts: 23130
Joined: Tue May 21, 2013 5:33 pm
Location: Saint-Lazare, west of MTL
Been liked: 11 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Sparky »

dannyc99 wrote:I will try and play with that tonight here is what I am concerned about

NO OR BAD VIDEO:
assuming the 13" monitor is working the first thing to suspect is the TMS9928 chip at u16, as this 40 pin chip is very problematic. If this chip is having problems the video will be distorted or wont sync properly. but u will have some sort of video.

This was taken from my repair manual.
http://www.arcadechips.com/product_info ... ucts_id=85

It's a 7$ chip. ;)
Patron saint of lost pinball causes.

Stage 5B. All except for NIB crap.

viewtopic.php?f=3&t=4742&p=40349&hilit=stages#p40349

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

HA HA Thanks so much Sparky..

I'm at work so I haven't even looked around for it.
That's a huge relief if it dose not sync tonight.

User avatar
Bally Boy
MAACA Millennial
Posts: 1094
Joined: Fri Nov 20, 2009 12:55 pm
Location: Ancaster, Ontario
Been liked: 1 time

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Bally Boy »

I'd make sure that monitor is working.... before you spend money on that IC chip.

I agree with Sparky, it looks like the game boots into attract mode, it might just be a video adjustment as it looks like something is on that monitor.

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

Is there such Thing as default or factory settings to start from

User avatar
Sparky
MAACA OG
Posts: 23130
Joined: Tue May 21, 2013 5:33 pm
Location: Saint-Lazare, west of MTL
Been liked: 11 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Sparky »

Nope, no default. Best thing you can do is just play with the vertical and horizontal adjustments. Before turning a knob, note their position. Then, turn them a bit to one side and the other by nothing their reaction on the screen. I put a mirror in front of the machine so I can see what happens from the back.
Patron saint of lost pinball causes.

Stage 5B. All except for NIB crap.

viewtopic.php?f=3&t=4742&p=40349&hilit=stages#p40349

User avatar
Gis
MAACA Chatterbox
Posts: 1793
Joined: Thu Sep 16, 2010 11:20 am
Location: Lachute

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Gis »

You're supposed to hear the pacman tune upon boot, if you don't get to hear it, your problem is bigger than the monitor. It would most likely mean a problem on the vidiot board.
Image

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

I get half the song

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

I need that chip.
Does anyone know of an arcade repair shop in Niagara or Hamilton that I maybe able to get one this weekend?
Apparently it is a fairly common chip used in other consoles.

texas instruments TMS9928.

User avatar
Sparky
MAACA OG
Posts: 23130
Joined: Tue May 21, 2013 5:33 pm
Location: Saint-Lazare, west of MTL
Been liked: 11 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Sparky »

dannyc99 wrote: Apparently it is a fairly common chip used in other consoles.
Yeah... but in 1982. You don't see many ColecoVision parts locally either. ;) The chip has been obsolete for a while. Best bet is to order one online.
Patron saint of lost pinball causes.

Stage 5B. All except for NIB crap.

viewtopic.php?f=3&t=4742&p=40349&hilit=stages#p40349

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »



OMG It's getting close.
The display isn't showing the board properly and when you go down the tunnel to pinball it goes wacky. same if you leave it in attract mode it shows for a while then flips to the same screen.

I can run all the self tests.
I ran the communications tests and it says the mpu and vidiot boards are communicating properly

User avatar
Sparky
MAACA OG
Posts: 23130
Joined: Tue May 21, 2013 5:33 pm
Location: Saint-Lazare, west of MTL
Been liked: 11 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by Sparky »

Looks like the entire game resets when the pinball portion is activated.

Power supply OK?
Patron saint of lost pinball causes.

Stage 5B. All except for NIB crap.

viewtopic.php?f=3&t=4742&p=40349&hilit=stages#p40349

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

ill look into it more. however when I go into the lamp solenoid tests everything is ok

User avatar
dannyc99
MAACA Silent Type
Posts: 96
Joined: Tue Aug 12, 2014 7:05 pm
Location: niagara falls

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by dannyc99 »

Im still leaning towards the same chip as I don't have proper video

User avatar
HPR Pinball
MAACA OG
Posts: 7471
Joined: Thu Sep 16, 2010 4:53 pm
Location: St-Rose, Laval
Has liked: 1 time
Been liked: 14 times

Re: My New Find "Bally's Baby Pac-Man" UPDATED!!

Post by HPR Pinball »

Good to see it's almost working !
Nice progress :)
Inventory
Pins: http://www.pinballowners.com/hal-9ooo
Vids: http://www.arcade-museum.com/members/me ... _id=454505
Les arcades, j'suis tombé d'dans quand j'tait pti !! :-)

Post Reply

Return to “Projects”