Page 1 of 1

Playmatic UFO-X

Posted: Wed Jan 15, 2020 9:20 am
by KADLAD
Hi
I have a UFO-X that is working but no sound. Have tried another sound board and still nothing. Not much info on the game. Is there anyone out there with a fully working game who might have some ideas on how to get the sound working or that has a working sound board. I am just about ready to give up.
Thanks Kim

Re: Playmatic UFO-X

Posted: Wed Jan 15, 2020 8:31 pm
by sylvain
Hi Kim,
I do not have such game, but I think we briefly talked at the last Ottawa Pinball & Gameroom show.

… Just to ensure you checked the usual:

- speaker, volume control and wiring all good, including plug to the sound board;
- supply voltages measured on the sound board and all are as expected;
- no chips too hot on the sound board (especially audio amp chip, if a chip);
- check for any open resistor, open/shorted diode or transistor;
- check for any cold solder joints, esp. at header connectors;
- wiring MPU to sound board is correct and good;
- do you have an ESR Cap tester to check electrolytic capacitors to ensure none are opened?
- Any self-test button on that soundboard?

Is there a way to simulate MPU signals at inputs of sound board to confirm if the issue is on the MPU, or on the soundboard?

Good luck!
-Sylvain.

Re: Playmatic UFO-X

Posted: Wed Jan 15, 2020 11:11 pm
by WARLOCK
Gents, I seem to recall discussing this in Ottawa briefly. Kim has parts from my machine to test his pin.
The only thing I can add is that I believe there are only 3 of us with this game in Canada that I am aware of.
Kim, myself and Bruno. I believe R.A.B. had mentioned to me that Mindstorm has a working copy. Just an FYI.
Cheers. Salut. (Excited to get all 3 running.)

Re: Playmatic UFO-X

Posted: Thu Jan 16, 2020 9:56 am
by KADLAD
Hi Scott
I tried you sound board and its the same as mine. Also tried your MPU board and game does not bootup. Sylvain We have scoped the signals coming from the CPU and they are getting to the sound board , but not getting past the 74C373 chip. Have tested the chip in an IC tester its good. So it looks like sound board trouble on both boards.Will keep trying .
Thanks Kim

Re: Playmatic UFO-X

Posted: Wed Jan 22, 2020 9:02 am
by KADLAD
We have sound. Last night Ian and I worked on the sound board look like CPU not starting CPU chip is new we made new software chips a long time ago from the interweb site. So there are 2 5101's one socketed the other not , pulled it and it tested ok. Ian started to swap the socketed chips starting with program chips which we had already remade. Plugged the board in and we had sound!!! So the file we had down loaded from the interweb was bad. So Scott your program chips are good.
Kim

Re: Playmatic UFO-X

Posted: Wed Jan 22, 2020 9:04 am
by WARLOCK
Kim, Good to hear your progress on this project. Well done. Scott