Need help troubleshooting sound board on GTB Arena 80b

Have questions on how to fix your machine or what products to use? This is the place to ask for help.
Post Reply
User avatar
Azatotht
Admins
Posts: 9204
Joined: Wed Nov 18, 2009 9:32 pm
Location: Anjou (Montreal)
Has liked: 396 times
Been liked: 119 times
Contact:

Need help troubleshooting sound board on GTB Arena 80b

Post by Azatotht »

Hi all,

On my GTB Arena, sounds and music were working and all of a sudden we turned the game on and there are no more sounds.

Game is in an ultra project state so I'm not sure if something is really broken or if it is just a connector issue. We got the dead display to work again after cleaning the board's connector traces so it might be a similar situation.

I searched on MAACA and came accross an old thread discussing that same issue with a Genesis and would like to try the test sequence that Atomicboy is discussing in it (viewtopic.php?t=2044).

So far:
- The light is flashing on the sound board
- I am hearing humms in the speakers and it is louder when I crank the pot volume up.
- I hear a small beep when I press the test button on the sound board.

From what I understand, I have a connector issue, a bad Z13 7404 chip on the driver board, or a bad Z31.

Now that's were I need help, can someone tell me where are the pins that I am supposed to short on the sound board in order to test if the sound board is working ? Here's exactly what i am talking about:
First, with the game in attract mode, you need to short pins on the sound board. You want to short to ground the Sound 1, 2, 4, 8 (and possibly 16 and 32, depending on the game). If you get a different sound as each of these through the speakers, your sound card is fine. If you do not, you have a sound board issue (unlikely you have a bad sound card).
I know these are related to to the connector but how can I test this without unplugging it ? And also, edge connectors are behing the board so should I remove it, are pins on the back of the board ?

Thanks for you help, once I've figured this out, if sounds are ok, I will move on to testing the Z13 chip but I'll keep that for the next question :FP: :mrgreen:
I am the monster that breathing men would kill.
I, am Dracula... (and you're not!)

Pinball machines I have owned

User avatar
Mindstorm88
MAACA Mega Contributor
Posts: 1364
Joined: Sat Nov 21, 2009 9:41 am
Location: Sorel-Tracy, Qc
Has liked: 53 times
Been liked: 66 times

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Mindstorm88 »

voir page 37 dans tes pm :D

User avatar
Azatotht
Admins
Posts: 9204
Joined: Wed Nov 18, 2009 9:32 pm
Location: Anjou (Montreal)
Has liked: 396 times
Been liked: 119 times
Contact:

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Azatotht »

Merci Bruno, donc, si je comprends bien, ce serait les pins du chip A3, celles qui sont du même coté que le connecteur ? Voir ma photo
IMG_2140.jpeg
I am the monster that breathing men would kill.
I, am Dracula... (and you're not!)

Pinball machines I have owned

User avatar
Mindstorm88
MAACA Mega Contributor
Posts: 1364
Joined: Sat Nov 21, 2009 9:41 am
Location: Sorel-Tracy, Qc
Has liked: 53 times
Been liked: 66 times

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Mindstorm88 »

les pins sont de chaque coté 3,4,7,8,13,14,17,18 , étant donné que sur la carte de sons, il y a des pullup sur chacune de ces pins tu dois toutes les mettre au ground et débrancher une a la fois pour l'activer
74LS374.png
74LS374.png (56.5 KiB) Viewed 332 times

User avatar
Azatotht
Admins
Posts: 9204
Joined: Wed Nov 18, 2009 9:32 pm
Location: Anjou (Montreal)
Has liked: 396 times
Been liked: 119 times
Contact:

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Azatotht »

Merci de faire mon éducation, c’est très apprécié.

Tu veux dire que les 8 pins doivent être au ground en même temps ou seulement une à la fois ?

Edit: ok j’ai compris le fonctionnement du pullup, une pin à la fois donc.
I am the monster that breathing men would kill.
I, am Dracula... (and you're not!)

Pinball machines I have owned

User avatar
Mindstorm88
MAACA Mega Contributor
Posts: 1364
Joined: Sat Nov 21, 2009 9:41 am
Location: Sorel-Tracy, Qc
Has liked: 53 times
Been liked: 66 times

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Mindstorm88 »

non, les 8 pins au ground en même temps , et tu débranche une a la fois pour l'activer( ou plus qu une pour faire du binaire )

User avatar
Azatotht
Admins
Posts: 9204
Joined: Wed Nov 18, 2009 9:32 pm
Location: Anjou (Montreal)
Has liked: 396 times
Been liked: 119 times
Contact:

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Azatotht »

Hummm ok, ca devient compliqué de les grounder tous en même temps il me semble, as-tu une technique simple pour faire cela ?
I am the monster that breathing men would kill.
I, am Dracula... (and you're not!)

Pinball machines I have owned

User avatar
Mindstorm88
MAACA Mega Contributor
Posts: 1364
Joined: Sat Nov 21, 2009 9:41 am
Location: Sorel-Tracy, Qc
Has liked: 53 times
Been liked: 66 times

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Mindstorm88 »

pas facile dans une machine , ca prend des jumper a petite pince,

User avatar
Azatotht
Admins
Posts: 9204
Joined: Wed Nov 18, 2009 9:32 pm
Location: Anjou (Montreal)
Has liked: 396 times
Been liked: 119 times
Contact:

Re: Need help troubleshooting sound board on GTB Arena 80b

Post by Azatotht »

Problem has been identified. It was the connectors.

Took a few days off before trying anything else and went back to it today.

Wiggled and pushed all related connectors properly, booted the game and there was music and sounds !

Sound card is good, everything is playing properly for now.

Thanks for your help Mindstorm88, you convinced me to leave the pins alone, didn't want to break it or short the wrong thing :FP: :mrgreen:
I am the monster that breathing men would kill.
I, am Dracula... (and you're not!)

Pinball machines I have owned

Post Reply